forked from termux/termux-packages
-
Notifications
You must be signed in to change notification settings - Fork 2
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Merge remote-tracking branch 'upstream/master'
- Loading branch information
Showing
14 changed files
with
42 additions
and
39 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,11 +1,11 @@ | ||
--- a/configure.ac | ||
+++ b/configure.ac | ||
@@ -260,7 +260,7 @@ | ||
AC_CHECK_LIB(iniparser,iniparser_load, have_iniparser=yes, have_iniparser=no) | ||
if [[ $have_iniparser = "yes" ]] ; then | ||
LIBS="$LIBS -liniparser" | ||
- CPPFLAGS="$CPPFLAGS -I/usr/include/iniparser" | ||
+ CPPFLAGS="$CPPFLAGS -I@TERMUX_PREFIX@/include/iniparser" | ||
@@ -429,7 +429,7 @@ | ||
CPPFLAGS="$CPPFLAGS -I/usr/local/include/iniparser/" | ||
CPPFLAGS="$CPPFLAGS -I/opt/homebrew/include/iniparser/" | ||
else | ||
- CPPFLAGS="$CPPFLAGS -I/usr/include/iniparser" | ||
+ CPPFLAGS="$CPPFLAGS -I@TERMUX_PREFIX@/include/iniparser" | ||
fi | ||
AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <iniparser.h>]], | ||
[[dictionary* ini; | ||
const char *keys[3]; |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file was deleted.
Oops, something went wrong.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,11 +1,11 @@ | ||
--- a/src/swtpm_setup/swtpm.c | ||
+++ b/src/swtpm_setup/swtpm.c | ||
@@ -70,7 +70,7 @@ | ||
unsigned ctr; | ||
@@ -92,7 +92,7 @@ | ||
int pidfile_fd; | ||
int ret = 1; | ||
gchar *tmp; | ||
- char pidfile[] = "/tmp/.swtpm_setup.pidfile.XXXXXX"; | ||
+ char pidfile[] = "@TERMUX_PREFIX@/tmp/.swtpm_setup.pidfile.XXXXXX"; | ||
|
||
pidfile_fd = mkstemp(pidfile); | ||
pidfile_fd = g_mkstemp_full(pidfile, O_EXCL|O_CREAT, 0600); | ||
if (pidfile_fd < 0) { |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters