forked from msys2/MINGW-packages
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
paraview: avoid file conflict with VTK
Fixes msys2#22149.
- Loading branch information
Showing
2 changed files
with
29 additions
and
4 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,22 @@ | ||
Avoid file conflict with VTK by appending a suffix to the library. | ||
See: https://github.com/msys2/MINGW-packages/issues/22149 | ||
|
||
diff -urN ParaView-v5.13.1/VTK/ThirdParty/vtkm/vtkvtkm/vtk-m/vtkm/thirdparty/diy/vtkmdiy/CMakeLists.txt.orig ParaView-v5.13.1/VTK/ThirdParty/vtkm/vtkvtkm/vtk-m/vtkm/thirdparty/diy/vtkmdiy/CMakeLists.txt | ||
--- VTK/ThirdParty/vtkm/vtkvtkm/vtk-m/vtkm/thirdparty/diy/vtkmdiy/CMakeLists.txt | ||
+++ VTK/ThirdParty/vtkm/vtkvtkm/vtk-m/vtkm/thirdparty/diy/vtkmdiy/CMakeLists.txt | ||
@@ -176,6 +176,15 @@ | ||
if (use_mpi AND TARGET MPI::MPI_CXX) | ||
target_link_libraries(${lib_name} PRIVATE MPI::MPI_CXX) | ||
endif() | ||
+ | ||
+ set(_lib_output_name "${lib_name}") | ||
+ if (_vtk_build_LIBRARY_NAME_SUFFIX) | ||
+ string(APPEND _lib_output_name "-${_vtk_build_LIBRARY_NAME_SUFFIX}") | ||
+ endif () | ||
+ | ||
+ set_target_properties(${lib_name} | ||
+ PROPERTIES | ||
+ OUTPUT_NAME "${_lib_output_name}") | ||
endfunction() | ||
|
||
# create the targets |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters