forked from msys2/MINGW-packages
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
- Loading branch information
1 parent
2af1aa3
commit da4f4c3
Showing
3 changed files
with
49 additions
and
31 deletions.
There are no files selected for viewing
37 changes: 37 additions & 0 deletions
37
mingw-w64-boost/0003-fix-build-context-with-CMake-on-arm64.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,37 @@ | ||
--- a/libs/context/CMakeLists.txt | ||
+++ b/libs/context/CMakeLists.txt | ||
@@ -89,18 +89,21 @@ | ||
else() | ||
set(_default_asm masm) | ||
endif() | ||
+elseif( CMAKE_CXX_COMPILER_ID STREQUAL Clang AND BOOST_CONTEXT_ARCHITECTURE STREQUAL arm64 AND WIN32 ) | ||
+ set(_default_asm armclang) | ||
else() | ||
set(_default_asm gas) | ||
endif() | ||
|
||
-set(BOOST_CONTEXT_ASSEMBLER "${_default_asm}" CACHE STRING "Boost.Context assembler (masm, gas, armasm)") | ||
-set_property(CACHE BOOST_CONTEXT_ASSEMBLER PROPERTY STRINGS masm gas armasm) | ||
+set(BOOST_CONTEXT_ASSEMBLER "${_default_asm}" CACHE STRING "Boost.Context assembler (masm, gas, armasm, armclang)") | ||
+set_property(CACHE BOOST_CONTEXT_ASSEMBLER PROPERTY STRINGS masm gas armasm armclang) | ||
|
||
unset(_default_asm) | ||
|
||
## Assembler source suffix | ||
- | ||
-if(BOOST_CONTEXT_BINARY_FORMAT STREQUAL pe) | ||
+if(BOOST_CONTEXT_ASSEMBLER STREQUAL armclang) | ||
+ set(_default_ext .S) | ||
+elseif(BOOST_CONTEXT_BINARY_FORMAT STREQUAL pe) | ||
set(_default_ext .asm) | ||
elseif(BOOST_CONTEXT_ASSEMBLER STREQUAL gas) | ||
set(_default_ext .S) | ||
@@ -135,7 +138,7 @@ | ||
# Enable the right assembler | ||
|
||
if(BOOST_CONTEXT_IMPLEMENTATION STREQUAL "fcontext") | ||
- if(BOOST_CONTEXT_ASSEMBLER STREQUAL gas) | ||
+ if(BOOST_CONTEXT_ASSEMBLER STREQUAL gas OR BOOST_CONTEXT_ASSEMBLER STREQUAL armclang) | ||
if(CMAKE_CXX_PLATFORM_ID MATCHES "Cygwin") | ||
enable_language(ASM-ATT) | ||
else() |
This file was deleted.
Oops, something went wrong.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters