Skip to content

Commit

Permalink
Merge pull request msys2#21483 from lazka/curl-8.9.0
Browse files Browse the repository at this point in the history
curl: Update to 8.9.0
  • Loading branch information
lazka authored Jul 24, 2024
2 parents 0021627 + 306bde4 commit 91f5c4c
Show file tree
Hide file tree
Showing 3 changed files with 7 additions and 61 deletions.
10 changes: 0 additions & 10 deletions mingw-w64-curl/0003-enable-soversion-on-mingw.patch

This file was deleted.

46 changes: 3 additions & 43 deletions mingw-w64-curl/0004-more-static-fixes.patch
Original file line number Diff line number Diff line change
@@ -1,46 +1,6 @@
--- a/CMake/FindBrotli.cmake
+++ b/CMake/FindBrotli.cmake
@@ -41,3 +41,4 @@

set(BROTLI_INCLUDE_DIRS ${BROTLI_INCLUDE_DIR})
set(BROTLI_LIBRARIES ${BROTLICOMMON_LIBRARY} ${BROTLIDEC_LIBRARY})
+set(LIBCURL_REQUIRES_PRIVATE "libbrotlidec ${LIBCURL_REQUIRES_PRIVATE}")
--- a/CMake/FindNGHTTP2.cmake
+++ b/CMake/FindNGHTTP2.cmake
@@ -37,5 +37,6 @@

set(NGHTTP2_INCLUDE_DIRS ${NGHTTP2_INCLUDE_DIR})
set(NGHTTP2_LIBRARIES ${NGHTTP2_LIBRARY})
+set(LIBCURL_REQUIRES_PRIVATE "libnghttp2 ${LIBCURL_REQUIRES_PRIVATE}")

mark_as_advanced(NGHTTP2_INCLUDE_DIRS NGHTTP2_LIBRARIES)
--- a/CMake/FindNGHTTP3.cmake
+++ b/CMake/FindNGHTTP3.cmake
@@ -73,6 +73,7 @@
if(NGHTTP3_FOUND)
set(NGHTTP3_LIBRARIES ${NGHTTP3_LIBRARY})
set(NGHTTP3_INCLUDE_DIRS ${NGHTTP3_INCLUDE_DIR})
+ set(LIBCURL_REQUIRES_PRIVATE "libnghttp3 ${LIBCURL_REQUIRES_PRIVATE}")
endif()

mark_as_advanced(NGHTTP3_INCLUDE_DIRS NGHTTP3_LIBRARIES)
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -886,6 +886,7 @@
check_library_exists("idn2" "idn2_lookup_ul" "" HAVE_LIBIDN2)
if(HAVE_LIBIDN2)
set(CURL_LIBS "idn2;${CURL_LIBS}")
+ set(LIBCURL_REQUIRES_PRIVATE "libidn2 ${LIBCURL_REQUIRES_PRIVATE}")
check_include_file_concat("idn2.h" HAVE_IDN2_H)
endif()
else()
--- a/libcurl.pc.in
+++ b/libcurl.pc.in
@@ -36,6 +36,8 @@
URL: https://curl.se/
Description: Library to transfer files with ftp, http, etc.
Version: @CURLVERSION@
+Requires.private: @LIBCURL_REQUIRES_PRIVATE@
--- curl-8.9.0/libcurl.pc.in.orig 2024-07-24 09:26:57.979608300 +0200
+++ curl-8.9.0/libcurl.pc.in 2024-07-24 09:30:11.854635400 +0200
@@ -38,3 +38,4 @@
Libs: -L${libdir} -lcurl @LIBCURL_NO_SHARED@
Libs.private: @LIBCURL_LIBS@
Cflags: -I${includedir} @CPPFLAG_CURL_STATICLIB@
Expand Down
12 changes: 4 additions & 8 deletions mingw-w64-curl/PKGBUILD
Original file line number Diff line number Diff line change
Expand Up @@ -6,8 +6,8 @@ pkgname=("${MINGW_PACKAGE_PREFIX}-${_realname}"
$([[ ${CARCH} == i686 ]] || echo \
"${MINGW_PACKAGE_PREFIX}-${_realname}-gnutls" \
"${MINGW_PACKAGE_PREFIX}-${_realname}-winssl"))
pkgver=8.8.0
pkgrel=10
pkgver=8.9.0
pkgrel=1
pkgdesc="Command line tool and library for transferring data with URLs (mingw-w64)"
arch=('any')
mingw_arch=('mingw32' 'mingw64' 'ucrt64' 'clang64' 'clang32' 'clangarm64')
Expand Down Expand Up @@ -46,15 +46,13 @@ source=("https://github.com/curl/curl/releases/download/${_realname}-${pkgver//.
"pathtools.c"
"pathtools.h"
"0001-Make-cURL-relocatable.patch"
"0003-enable-soversion-on-mingw.patch"
"0004-more-static-fixes.patch")
sha256sums=('0f58bb95fc330c8a46eeb3df5701b0d90c9d9bfcc42bd1cd08791d12551d4400'
sha256sums=('ff09b2791ca56d25fd5c3f3a4927dce7c8a9dc4182200c487ca889fba1fdd412'
'SKIP'
'ebf471173f5ee9c4416c10a78760cea8afaf1a4a6e653977321e8547ce7bf3c0'
'1585ef1b61cf53a2ca27049c11d49e0834683dfda798f03547761375df482a90'
'67cafabd99ad1e636e042d052409afdfb52de4e3893b47413ad366e486c1c0a7'
'f411ae7662fc67ff52bdc7d42a92e255e52154bb7d06251694802ba8d709319d'
'78a74e955ed1d0dfe9915891139cfe4feefc6c0d80fc38cf4da8697cf0d603d3')
'dbfdcd3be9588234174ea264e9371dab5e834572f4005dd4baa0a6da53ef9f8f')
validpgpkeys=('27EDEAF22F3ABCEB50DB9A125CC908FDB71E12C2') # Daniel Stenberg

apply_patch_with_msg() {
Expand All @@ -76,7 +74,6 @@ prepare() {

apply_patch_with_msg \
0001-Make-cURL-relocatable.patch \
0003-enable-soversion-on-mingw.patch \
0004-more-static-fixes.patch
}

Expand Down Expand Up @@ -131,7 +128,6 @@ do_build() {
"${MINGW_PREFIX}"/bin/cmake.exe \
-GNinja \
-DCMAKE_INSTALL_PREFIX="${MINGW_PREFIX}" \
-DCMAKE_FIND_STATIC_LIBRARIES=ON \
-DCMAKE_UNITY_BUILD=ON \
"${_extra_config[@]}" \
"${_variant_config[@]}" \
Expand Down

0 comments on commit 91f5c4c

Please sign in to comment.