forked from msys2/MINGW-packages
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
- Loading branch information
1 parent
db27692
commit 5b2c212
Showing
3 changed files
with
21 additions
and
28 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,15 @@ | ||
--- a/plugins/auth/CMakeLists.txt | ||
+++ b/plugins/auth/CMakeLists.txt | ||
@@ -69,9 +69,11 @@ | ||
INCLUDES ${REF10_DIR} | ||
LIBRARIES ${CRYPT_LIBS} | ||
COMPILE_OPTIONS -DMYSQL_CLIENT=1) | ||
+ if(TARGET client_ed25519) | ||
SET_PROPERTY(TARGET client_ed25519 PROPERTY C_STANDARD 11) | ||
+ endif() | ||
|
||
- IF(HAVE_C_THREAD_LOCAL) | ||
+ IF(HAVE_C_THREAD_LOCAL AND TARGET client_ed25519) | ||
TARGET_COMPILE_DEFINITIONS(client_ed25519 PRIVATE -DHAVE_THREAD_LOCAL) | ||
ENDIF() | ||
|
This file was deleted.
Oops, something went wrong.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -3,8 +3,8 @@ | |
_realname=libmariadbclient | ||
pkgbase=mingw-w64-${_realname} | ||
pkgname="${MINGW_PACKAGE_PREFIX}-${_realname}" | ||
pkgver=3.3.8 | ||
pkgrel=2 | ||
pkgver=3.4.1 | ||
pkgrel=1 | ||
pkgdesc="MariaDB client libraries (mingw-w64)" | ||
arch=('any') | ||
mingw_arch=('mingw64' 'ucrt64' 'clang64' 'clangarm64') | ||
|
@@ -24,12 +24,12 @@ depends=("${MINGW_PACKAGE_PREFIX}-curl" | |
"${MINGW_PACKAGE_PREFIX}-zstd") | ||
source=(https://mirror.rackspace.com/mariadb/connector-c-${pkgver}/mariadb-connector-c-${pkgver}-src.tar.gz{,.asc} | ||
001-mingw-build.patch | ||
002-fix-prototype.patch | ||
002-fix-cmake-configure.patch | ||
003-gcc-fix-use_VA_ARGS.patch) | ||
sha256sums=('f9f076b4aa9fb22cc94b24f82c80f9ef063805ecd6533a2eb5d5060cf93833e8' | ||
sha256sums=('0a7f2522a44a7369c1dda89676e43485037596a7b1534898448175178aedeb4d' | ||
'SKIP' | ||
'64ad2b8c85fb369c20c1941c896c2a7d5202a8b7259e9e31922c8d0bfcbfd198' | ||
'346695ce8f10c2c426f880240ef7bbe7b8d70c6e58b0cc30483735c2b2d53261' | ||
'44aabb02066511d387b75a492aa824ac12a5439969494b497e3225206f879197' | ||
'fc08055e5d63e310e2658b15f6e1f00b59f2aad2dec37560c01954fac6af4a6e') | ||
validpgpkeys=("177F4010FE56CA3336300305F1656F24C74CD1D8") #MariaDB Package Signing Key <[email protected]> | ||
|
||
|
@@ -45,7 +45,7 @@ prepare() { | |
cd ${srcdir}/mariadb-connector-c-${pkgver}-src | ||
apply_patch_with_msg \ | ||
001-mingw-build.patch \ | ||
002-fix-prototype.patch \ | ||
002-fix-cmake-configure.patch \ | ||
003-gcc-fix-use_VA_ARGS.patch | ||
} | ||
|
||
|