Skip to content

Commit

Permalink
goxel: update to 0.15.1
Browse files Browse the repository at this point in the history
  • Loading branch information
podsvirov committed Oct 2, 2024
1 parent f77c551 commit 4b8b410
Show file tree
Hide file tree
Showing 2 changed files with 21 additions and 29 deletions.
40 changes: 16 additions & 24 deletions mingw-w64-goxel/001-goxel-0.11.0-msys-mingw.patch
Original file line number Diff line number Diff line change
@@ -1,44 +1,36 @@
diff --git a/Makefile b/Makefile
index 18e07a60..616fbf81 100644
--- a/Makefile
+++ b/Makefile
@@ -11,7 +11,7 @@ all:
scons $(JOBS)

release:
- scons $(JOBS) mode=release
+ ${MINGW_PREFIX}/bin/scons mode=release werror=no

profile:
scons $(JOBS) mode=profile
diff --git a/SConstruct b/SConstruct
index 82bcc449..0e013cba 100644
--- a/SConstruct
+++ b/SConstruct
@@ -29,9 +29,9 @@ vars.AddVariables(
--- goxel-0.15.1.orig/SConstruct 2024-10-02 19:06:19.126876200 +0300
+++ goxel-0.15.1/SConstruct 2024-10-02 20:45:05.594228100 +0300
@@ -29,7 +29,7 @@
PathVariable('config_file', 'Config file to use', 'src/config.h'),
)

-target_os = str(Platform())
+target_os = 'msys'

-env = Environment(variables = vars, ENV = os.environ)
+env = Environment(tools = ['mingw'], variables = vars, ENV = os.environ)
if target_os == 'posix':
vars.AddVariables(
@@ -38,7 +38,7 @@
)


-env = Environment(variables=vars, ENV=os.environ)
+env = Environment(tools=['mingw'], variables=vars, ENV=os.environ)
conf = env.Configure()

if env['mode'] == 'analyze':
@@ -99,12 +99,10 @@ if target_os == 'posix':
@@ -116,13 +116,11 @@
env.Append(CXXFLAGS=['-Wno-attributes', '-Wno-unused-variable',
'-Wno-unused-function'])
env.Append(CCFLAGS=['-Wno-error=address']) # To remove if possible.
- env.Append(LIBS=['glfw3', 'opengl32', 'z', 'tre', 'gdi32', 'Comdlg32',
- 'ole32'],
- 'ole32', 'uuid', 'shell32'],
- LINKFLAGS='--static')
- sources += glob.glob('ext_src/glew/glew.c')
+ env.Append(LIBS=['pthread', 'opengl32', 'z', 'tre', 'gdi32', 'Comdlg32',
+ 'ole32', 'uuid', 'shell32'])
sources.append('ext_src/nfd/nfd_win.cpp')
- env.Append(CPPPATH=['ext_src/glew'])
- env.Append(CPPDEFINES=['GLEW_STATIC', 'FREE_WINDOWS'])
+ env.Append(LIBS=['opengl32', 'z', 'tre', 'pthread', 'gdi32', 'Comdlg32',
+ 'ole32'])
+ env.ParseConfig('pkg-config --cflags --libs glfw3 glew')
+ env.Append(CPPDEFINES=['FREE_WINDOWS'])

Expand Down
10 changes: 5 additions & 5 deletions mingw-w64-goxel/PKGBUILD
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@
_realname=goxel
pkgbase=mingw-w64-${_realname}
pkgname=${MINGW_PACKAGE_PREFIX}-${_realname}
pkgver=0.14.0
pkgver=0.15.1
pkgrel=1
pkgdesc="3D program that lets you create voxel volumes (mingw-w64)"
arch=('any')
Expand All @@ -21,10 +21,10 @@ makedepends=("${MINGW_PACKAGE_PREFIX}-cc"
"${MINGW_PACKAGE_PREFIX}-scons"
"${MINGW_PACKAGE_PREFIX}-pkgconf"
"${MINGW_PACKAGE_PREFIX}-winpthreads")
source=("https://github.com/guillaumechereau/goxel/archive/v$pkgver/$_realname-$pkgver.tar.gz"
source=("${msys2_repository_url}/archive/v$pkgver/$_realname-$pkgver.tar.gz"
"001-goxel-0.11.0-msys-mingw.patch")
sha256sums=('f22aef2cd520f0a13a6fb08c63c6c0f8abc9c9814b6e9ce8978fc834a1824696'
'1fbf2be2999772a5907dcae47cc1132a7e581262afb7025e0f8aa5bdd6592bbe')
sha256sums=('01c9601ac9d8d38e29d3adff4b79a26c2b9fea4c2d2cb1d134471e499f8c4a84'
'63af4960ecb3ac5eb43eeb89395512372b7614a72b193a225dc41893dee6a971')

prepare() {
cd $_realname-$pkgver
Expand All @@ -39,7 +39,7 @@ build() {
cp -r "${_realname}-${pkgver}" "build-${MSYSTEM}"
cd "${srcdir}/build-${MSYSTEM}"

make release
"${MINGW_PREFIX}"/bin/scons mode=release werror=no
}

package() {
Expand Down

0 comments on commit 4b8b410

Please sign in to comment.