Skip to content

Commit

Permalink
llvm-19 rebuilds
Browse files Browse the repository at this point in the history
  • Loading branch information
MehdiChinoune committed Nov 12, 2024
1 parent 313806e commit 3c728ca
Show file tree
Hide file tree
Showing 9 changed files with 70 additions and 23 deletions.
2 changes: 1 addition & 1 deletion mingw-w64-arrow/PKGBUILD
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@ _realname=arrow
pkgbase=mingw-w64-${_realname}
pkgname="${MINGW_PACKAGE_PREFIX}-${_realname}"
pkgver=18.0.0
pkgrel=1
pkgrel=2
pkgdesc="Apache Arrow is a cross-language development platform for in-memory data (mingw-w64)"
arch=(any)
mingw_arch=('mingw64' 'ucrt64' 'clang64' 'clangarm64')
Expand Down
24 changes: 12 additions & 12 deletions mingw-w64-castxml/PKGBUILD
Original file line number Diff line number Diff line change
Expand Up @@ -4,20 +4,19 @@ _realname=castxml
pkgbase=mingw-w64-${_realname}
pkgname=("${MINGW_PACKAGE_PREFIX}-${_realname}")
pkgver=0.6.8
pkgrel=1
pkgrel=2
pkgdesc="C-family abstract syntax tree XML output tool. (mingw-w64)"
arch=('any')
mingw_arch=('mingw64' 'ucrt64' 'clang64' 'clangarm64')
url='https://github.com/CastXML/CastXML'
license=(Apache)
depends=("${MINGW_PACKAGE_PREFIX}-llvm"
"${MINGW_PACKAGE_PREFIX}-clang"
"${MINGW_PACKAGE_PREFIX}-clang-tools-extra")
makedepends=("${MINGW_PACKAGE_PREFIX}-cmake"
license=(spdx:Apache-2.0)
depends=("${MINGW_PACKAGE_PREFIX}-clang-libs")
makedepends=("${MINGW_PACKAGE_PREFIX}-cc"
"${MINGW_PACKAGE_PREFIX}-cmake"
"${MINGW_PACKAGE_PREFIX}-ninja"
"${MINGW_PACKAGE_PREFIX}-cc"
"${MINGW_PACKAGE_PREFIX}-clang-tools-extra"
"${MINGW_PACKAGE_PREFIX}-python-sphinx")
source=(${_realname}-${pkgver}.tar.gz::https://github.com/CastXML/CastXML/archive/v${pkgver}.tar.gz)
source=(https://github.com/CastXML/CastXML/archive/v${pkgver}/${_realname}-${pkgver}.tar.gz)
sha256sums=('b517a9d18ddb7f71b3b053af61fc393dd81f17911e6c6d53a85f3f523ba8ad64')

build() {
Expand All @@ -34,9 +33,9 @@ build() {
-DCMAKE_INSTALL_PREFIX="${MINGW_PREFIX}" \
"${extra_config[@]}" \
-DCLANG_LINK_CLANG_DYLIB=1 \
-DSPHINX_EXECUTABLE=/usr/bin/sphinx-build \
-DSPHINX_HTML=0 \
-DSPHINX_MAN=0 \
-DSPHINX_EXECUTABLE=${MINGW_PREFIX}/bin/sphinx-build \
-DSPHINX_HTML=OFF \
-DSPHINX_MAN=OFF \
-DCastXML_INSTALL_DOC_DIR=share/doc/castxml \
-DCastXML_INSTALL_MAN_DIR=share/man \
-S "${_realname}-${pkgver}" \
Expand All @@ -48,5 +47,6 @@ build() {
package() {
DESTDIR="${pkgdir}" "${MINGW_PREFIX}"/bin/cmake.exe --install "build-${MSYSTEM}"

install -Dm644 "${srcdir}/${_realname}-${pkgver}/LICENSE" "${pkgdir}${MINGW_PREFIX}/share/licenses/${_realname}/LICENSE"
install -Dm644 "${srcdir}/${_realname}-${pkgver}/LICENSE" \
"${pkgdir}${MINGW_PREFIX}/share/licenses/${_realname}/LICENSE"
}
2 changes: 1 addition & 1 deletion mingw-w64-cvise/PKGBUILD
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@ _realname=cvise
pkgbase=mingw-w64-${_realname}
pkgname=("${MINGW_PACKAGE_PREFIX}-${_realname}")
pkgver=2.11.0
pkgrel=1
pkgrel=2
pkgdesc="Super-parallel Python port of the C-Reduce (mingw-w64)"
arch=('any')
mingw_arch=('mingw64' 'ucrt64' 'clang64' 'clangarm64')
Expand Down
1 change: 1 addition & 0 deletions mingw-w64-ghdl/.gitignore
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
001-support-llvm-19.patch
13 changes: 10 additions & 3 deletions mingw-w64-ghdl/PKGBUILD
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@ pkgbase="mingw-w64-${_realname}"
pkgname=("${MINGW_PACKAGE_PREFIX}-${_realname}-llvm"
"${MINGW_PACKAGE_PREFIX}-${_realname}-mcode")
pkgver=4.1.0
pkgrel=3
pkgrel=4
pkgdesc='GHDL: the open-source analyzer, compiler, simulator and (experimental) synthesizer for VHDL'
arch=('any')
mingw_arch=('mingw64' 'ucrt64')
Expand All @@ -22,8 +22,15 @@ makedepends=(
)
checkdepends=("${MINGW_PACKAGE_PREFIX}-python-pytest")
options=(!emptydirs)
source=("https://github.com/ghdl/ghdl/archive/v${pkgver}/${_realname}-${pkgver}.tar.gz")
sha256sums=('0aab531b45a6613b0918f3ac6ec717b8acfad051d1abb1c39eb7490590c7a324')
source=("https://github.com/ghdl/ghdl/archive/v${pkgver}/${_realname}-${pkgver}.tar.gz"
001-support-llvm-19.patch::https://github.com/ghdl/ghdl/commit/6a9c70dd.patch)
sha256sums=('0aab531b45a6613b0918f3ac6ec717b8acfad051d1abb1c39eb7490590c7a324'
'e3792de2e2cbd6ef96a53d9f2a1f025bc5f88c063ae523979e86e95a47a09841')

prepare() {
cd ${_realname}-${pkgver}
patch -p1 -i ${srcdir}/001-support-llvm-19.patch
}

build() {
echo "Building ghdl-llvm..."
Expand Down
2 changes: 1 addition & 1 deletion mingw-w64-mesa/PKGBUILD
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@ _realname=mesa
pkgbase=mingw-w64-${_realname}
pkgname="${MINGW_PACKAGE_PREFIX}-${_realname}"
pkgver=24.2.6
pkgrel=1
pkgrel=2
pkgdesc="Open-source implementation of the OpenGL, Vulkan and OpenCL specifications (mingw-w64)"
url="https://www.mesa3d.org/"
msys2_references=(
Expand Down
28 changes: 28 additions & 0 deletions mingw-w64-qt-creator/005-fix-build-with-clang-19.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,28 @@
--- a/src/libs/3rdparty/sol2/include/sol/sol.hpp
+++ b/src/libs/3rdparty/sol2/include/sol/sol.hpp
@@ -6818,7 +6818,8 @@
static_assert(std::is_constructible<T, Args&&...>::value, "T must be constructible with Args");

*this = nullopt;
- this->construct(std::forward<Args>(args)...);
+ new (static_cast<void*>(this)) optional(std::in_place, std::forward<Args>(args)...);
+ return **this;
}

/// Swaps this optional with the other.
--- a/src/libs/utils/algorithm.h
+++ b/src/libs/utils/algorithm.h
@@ -259,5 +259,5 @@
typename ResultContainer = C<Result>>
Q_REQUIRED_RESULT decltype(auto) transform(SC &&container, F function);
-#ifdef Q_CC_CLANG
+#if defined(Q_CC_CLANG) && !defined(__cpp_template_template_args)
// "Matching of template template-arguments excludes compatible templates"
// http://www.open-std.org/jtc1/sc22/wg21/docs/papers/2016/p0522r0.html (P0522R0)
@@ -810,5 +810,5 @@
}

-#ifdef Q_CC_CLANG
+#if defined(Q_CC_CLANG) && !defined(__cpp_template_template_args)
template<template<typename, typename> class C, // result container type
typename SC, // input container type
19 changes: 15 additions & 4 deletions mingw-w64-qt-creator/PKGBUILD
Original file line number Diff line number Diff line change
Expand Up @@ -8,7 +8,7 @@ pkgname=("${MINGW_PACKAGE_PREFIX}-${_realname}"
"${MINGW_PACKAGE_PREFIX}-${_realname}-devel")
_base_ver=14.0.1
pkgver=${_base_ver/-/}
pkgrel=2
pkgrel=3
pkgdesc='Lightweight, cross-platform integrated development environment (mingw-w64)'
arch=('any')
mingw_arch=('mingw64' 'ucrt64' 'clang64' 'clangarm64')
Expand Down Expand Up @@ -41,11 +41,15 @@ _pkgfqn="${_realname}-opensource-src-${_base_ver}"
source=(https://download.qt.io/official_releases/qtcreator/${_base_ver%.*}/${_base_ver}/${_pkgfqn}.tar.xz
qt-creator-3.2.0-Allow-iOS-plugin-on-any-platform.patch
qt-creator-5.0.1-fix-library-archive-path.patch
003-link-against-clang-cpp.patch)
003-link-against-clang-cpp.patch
004-support-llvm-19.patch::https://invent.kde.org/qt/qt-creator/qt-creator/-/commit/711c6d85.patch
005-fix-build-with-clang-19.patch)
sha256sums=('9595d2e6c65bb918e78376314341dc2bef491c3200a5c6d5ce6f305509b0b28b'
'd53c00ab39d0fd16c03a1031fdb4e96f817ef120575866f4f03b307e521438bd'
'29d67f88f071abe7a4b589182767b8a697fe4e516d70707bfca88f035883718f'
'5d6c0b626ef29ce39372eb180527d64e11af2bf39a1a3e84e709464a20d2433b')
'5d6c0b626ef29ce39372eb180527d64e11af2bf39a1a3e84e709464a20d2433b'
'c8ee06da9c9c181b5f11851b82b9bd3b28b7396c3cd7b3cef1e09aa800bd8c09'
'8cd86db9560698e86f8bac61294c8e6b5f23ad07ce4d3e87c266e1f731fff8aa')

apply_patch_with_msg() {
for _patch in "$@"
Expand All @@ -61,7 +65,9 @@ prepare() {
apply_patch_with_msg \
qt-creator-3.2.0-Allow-iOS-plugin-on-any-platform.patch \
qt-creator-5.0.1-fix-library-archive-path.patch \
003-link-against-clang-cpp.patch
003-link-against-clang-cpp.patch \
004-support-llvm-19.patch \
005-fix-build-with-clang-19.patch
}

build() {
Expand All @@ -74,6 +80,11 @@ build() {
_extra_config+=("-DCMAKE_BUILD_TYPE=Debug")
fi

if [[ ${MINGW_PACKAGE_PREFIX} == *-clang-* ]]; then
_extra_config+=("-DWITH_QMLDESIGNER=OFF")
fi

CXXFLAGS+=" -Wno-deprecated-declarations" \
MSYS2_ARG_CONV_EXCL="-DCMAKE_INSTALL_PREFIX=" \
${MINGW_PREFIX}/bin/cmake.exe \
-GNinja \
Expand Down
2 changes: 1 addition & 1 deletion mingw-w64-qt6-tools/PKGBUILD
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,7 @@ pkgname=("${MINGW_PACKAGE_PREFIX}-${_realname}"
"${MINGW_PACKAGE_PREFIX}-${_realname}-debug")
_qtver=6.8.0
pkgver=${_qtver/-/}
pkgrel=1
pkgrel=2
pkgdesc='A cross-platform application and UI framework (Development Tools, QtHelp) (mingw-w64)'
arch=(any)
mingw_arch=('mingw64' 'ucrt64' 'clang64' 'clangarm64')
Expand Down

0 comments on commit 3c728ca

Please sign in to comment.