Skip to content

Commit

Permalink
Merge pull request #1556 from nxhack/dev_22.03
Browse files Browse the repository at this point in the history
[22.03] node: v14.x EoL, add v20.x
  • Loading branch information
nxhack authored May 8, 2023
2 parents 7786efb + 18dc2fe commit 209d473
Show file tree
Hide file tree
Showing 14 changed files with 196 additions and 289 deletions.
16 changes: 8 additions & 8 deletions node/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -12,11 +12,11 @@ PKG_RELEASE:=1
PKG_HASH:=e0990f992234e40a51fe11f92c3816c93a77e1b081145d3dd762cd1026345349
PATCH_DIR:=./patches/v16.x
else
ifeq ($(CONFIG_NODEJS_14),y)
PKG_VERSION:=v14.21.3
ifeq ($(CONFIG_NODEJS_20),y)
PKG_VERSION:=v20.1.0
PKG_RELEASE:=1
PKG_HASH:=458ec092e60ad700ddcf079cb63d435c15da4c7bb3d3f99b9a8e58a99e54075e
PATCH_DIR:=./patches/v14.x
PKG_HASH:=600f9e11860995814b9122b1ac5318f6ad564274784deed98d8a9206649436b5
PATCH_DIR:=./patches/v20.x
else
PKG_VERSION:=v18.16.0
PKG_RELEASE:=1
Expand Down Expand Up @@ -86,19 +86,19 @@ define Package/node/config

choice
prompt "Version Selection"
default NODEJS_16
default NODEJS_18
help
Select node.js version.
The host package version is also the same.

config NODEJS_14
bool "14.x Maintenance"

config NODEJS_16
bool "16.x Maintenance"

config NODEJS_18
bool "18.x Active LTS"

config NODEJS_20
bool "20.x Current"
endchoice

if PACKAGE_node
Expand Down
208 changes: 0 additions & 208 deletions node/patches/v14.x/010-execvp-arg-list-too-long.patch

This file was deleted.

20 changes: 0 additions & 20 deletions node/patches/v14.x/012-changing-default-npm-settings.patch

This file was deleted.

This file was deleted.

Original file line number Diff line number Diff line change
@@ -1,12 +1,12 @@
--- a/lib/internal/modules/cjs/loader.js
+++ b/lib/internal/modules/cjs/loader.js
@@ -1231,7 +1231,8 @@ Module._initPaths = function() {
@@ -1404,7 +1404,8 @@ Module._initPaths = function() {
path.resolve(process.execPath, '..') :
path.resolve(process.execPath, '..', '..');

- let paths = [path.resolve(prefixDir, 'lib', 'node')];
+ let paths = [path.resolve(prefixDir, 'lib', 'node'),
+ path.resolve(prefixDir, 'lib', 'node_modules')];
- const paths = [path.resolve(prefixDir, 'lib', 'node')];
+ const paths = [path.resolve(prefixDir, 'lib', 'node'),
+ path.resolve(prefixDir, 'lib', 'node_modules')];

if (homeDir) {
ArrayPrototypeUnshift(paths, path.resolve(homeDir, '.node_libraries'));
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- a/deps/v8/src/base/platform/condition-variable.cc
+++ b/deps/v8/src/base/platform/condition-variable.cc
@@ -16,7 +16,7 @@ namespace base {
@@ -20,7 +20,7 @@ namespace base {

ConditionVariable::ConditionVariable() {
#if (V8_OS_FREEBSD || V8_OS_NETBSD || V8_OS_OPENBSD || \
Expand All @@ -9,7 +9,7 @@
// On Free/Net/OpenBSD and Linux with glibc we can change the time
// source for pthread_cond_timedwait() to use the monotonic clock.
pthread_condattr_t attr;
@@ -92,7 +92,7 @@ bool ConditionVariable::WaitFor(Mutex* m
@@ -96,7 +96,7 @@ bool ConditionVariable::WaitFor(Mutex* m
&native_handle_, &mutex->native_handle(), &ts);
#else
#if (V8_OS_FREEBSD || V8_OS_NETBSD || V8_OS_OPENBSD || \
Expand All @@ -20,8 +20,8 @@
result = clock_gettime(CLOCK_MONOTONIC, &ts);
--- a/deps/v8/src/base/platform/platform-posix.cc
+++ b/deps/v8/src/base/platform/platform-posix.cc
@@ -839,7 +839,7 @@ bool Thread::Start() {
#if V8_OS_MACOSX
@@ -1141,7 +1141,7 @@ bool Thread::Start() {
#if V8_OS_DARWIN
// Default on Mac OS X is 512kB -- bump up to 1MB
stack_size = 1 * 1024 * 1024;
-#elif V8_OS_AIX
Expand All @@ -31,12 +31,12 @@
#endif
--- a/deps/v8/src/codegen/external-reference-table.cc
+++ b/deps/v8/src/codegen/external-reference-table.cc
@@ -9,7 +9,7 @@
@@ -10,7 +10,7 @@
#include "src/ic/stub-cache.h"
#include "src/logging/counters.h"

-#if defined(DEBUG) && defined(V8_OS_LINUX) && !defined(V8_OS_ANDROID)
+#if defined(DEBUG) && defined(V8_OS_LINUX) && !defined(V8_OS_ANDROID) && defined(V8_LIBC_GLIBC)
#define SYMBOLIZE_FUNCTION
#include <execinfo.h>
#include <vector>

Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- a/tools/gyp/pylib/gyp/generator/make.py
+++ b/tools/gyp/pylib/gyp/generator/make.py
@@ -180,7 +180,7 @@ cmd_solink_module = $(LINK.$(TOOLSET)) -
@@ -206,7 +206,7 @@ cmd_solink_module = $(LINK.$(TOOLSET)) -

LINK_COMMANDS_MAC = """\
quiet_cmd_alink = LIBTOOL-STATIC $@
Expand Down
20 changes: 20 additions & 0 deletions node/patches/v20.x/012-changing-default-npm-settings.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,20 @@
--- a/deps/npm/lib/utils/config/definitions.js
+++ b/deps/npm/lib/utils/config/definitions.js
@@ -1266,7 +1266,7 @@ define('lockfile-version', {
})

define('loglevel', {
- default: 'notice',
+ default: 'info',
type: [
'silent',
'error',
@@ -2045,7 +2045,7 @@ define('strict-peer-deps', {
})

define('strict-ssl', {
- default: true,
+ default: false,
type: Boolean,
description: `
Whether or not to do SSL key validation when making requests to the
Loading

0 comments on commit 209d473

Please sign in to comment.