-
Notifications
You must be signed in to change notification settings - Fork 78
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
addpatch: deepin-screen-recorder 5.12.15
upstreamed: https://gitlab.archlinux.org/archlinux/packaging/packages/deepin-screen-recorder/-/merge_requests/2
- Loading branch information
Showing
2 changed files
with
48 additions
and
0 deletions.
There are no files selected for viewing
34 changes: 34 additions & 0 deletions
34
deepin-screen-recorder/deepin-screen-recorder-unqualified-id.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,34 @@ | ||
From 232cefdc61cf9425f9d30ca71160c9d74587fca7 Mon Sep 17 00:00:00 2001 | ||
From: Hillwood Yang <[email protected]> | ||
Date: Mon, 20 Nov 2023 21:43:03 +0800 | ||
Subject: [PATCH] fix: Fix unqualified-id error | ||
|
||
Fix https://github.com/linuxdeepin/developer-center/issues/6238 | ||
|
||
Log: It seems that QUICK_ITEM_KEY conflicts with some keywords. | ||
--- | ||
src/dde-dock-plugins/shotstart/shotstartplugin.cpp | 4 ++-- | ||
1 file changed, 2 insertions(+), 2 deletions(-) | ||
|
||
diff --git a/src/dde-dock-plugins/shotstart/shotstartplugin.cpp b/src/dde-dock-plugins/shotstart/shotstartplugin.cpp | ||
index 699eeb6d..7d5e8815 100755 | ||
--- a/src/dde-dock-plugins/shotstart/shotstartplugin.cpp | ||
+++ b/src/dde-dock-plugins/shotstart/shotstartplugin.cpp | ||
@@ -10,7 +10,7 @@ | ||
|
||
#define ShotShartPlugin "shot-start-plugin" | ||
#define ShotShartApp "deepin-screen-recorder" // 使用截图录屏的翻译 | ||
-const QString QUICK_ITEM_KEY = QStringLiteral("quick_item_key"); | ||
+const QString QUICK_ITEM = QStringLiteral("quick_item_key"); | ||
|
||
ShotStartPlugin::ShotStartPlugin(QObject *parent) | ||
: QObject(parent), m_iconWidget(nullptr),m_quickPanelWidget(nullptr), m_tipsWidget(nullptr) | ||
@@ -103,7 +103,7 @@ QWidget *ShotStartPlugin::itemWidget(const QString &itemKey) | ||
// if (itemKey != ShotShartPlugin) return nullptr; | ||
|
||
qInfo() << "Current itemWidget's itemKey: " << itemKey; | ||
- if(itemKey == QUICK_ITEM_KEY){ | ||
+ if(itemKey == QUICK_ITEM){ | ||
qInfo() << "Input Quick Panel Widget!"; | ||
return m_quickPanelWidget.data(); | ||
}else if (itemKey == ShotShartPlugin){ |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,14 @@ | ||
--- PKGBUILD | ||
+++ PKGBUILD | ||
@@ -18,9 +18,9 @@ provides=('deepin-screenshot') | ||
conflicts=('deepin-screenshot') | ||
groups=('deepin-extra') | ||
source=("https://github.com/linuxdeepin/deepin-screen-recorder/archive/$pkgver/$pkgname-$pkgver.tar.gz" | ||
- $pkgname-unqualified-id.patch::https://github.com/linuxdeepin/deepin-screen-recorder/pull/416.patch) | ||
+ "$pkgname-unqualified-id.patch") | ||
sha512sums=('9e9281918b27b34e27f9f7c2ef7b490eda272adc63370fb2908fd98735983467195cc24a466ca3b9a04e7e6a1b622eb905158da513947b633b434882fe797fa2' | ||
- '5b26c7127cde0ae041ca53ab87edb3ea341d883f7d204f03e697175245c5ad564f9f0e30448fb291cff34fa26d03e1ee2dec4d368527f0bb217b086d7f1dde78') | ||
+ '5624a25292b0d4f74aa73c1374c51d9098db8a6984e9586da1f88349c0315e2dde1cb6f3b26ac7db6fd04044b9283238ab93a607be6883f746b0e1a57e8c3ce3') | ||
|
||
prepare() { | ||
cd deepin-screen-recorder-$pkgver |