-
-
Notifications
You must be signed in to change notification settings - Fork 21
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
(feat): restore project to working state
- Loading branch information
1 parent
08d90ab
commit cce37af
Showing
48 changed files
with
617 additions
and
1,260 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file was deleted.
Oops, something went wrong.
File renamed without changes.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,6 @@ | ||
Make sure you check the following: | ||
* [ ] unless trivial, a corresponding issue exists for this PR (reference it) | ||
* [ ] if this PR fixes the issue, then include `fix #` and the issue number | ||
* [ ] if this PR adds a feature, then you've included tests in `spec/` | ||
* [ ] you've ran `gulp test` and it passes the lint and spec | ||
* [ ] you've prepended the PR description i.e. (chore):, (feat):, (fix): |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,6 +1,8 @@ | ||
node_modules | ||
jspm_packages | ||
bower_components | ||
.idea | ||
.DS_STORE | ||
build/reports | ||
dist/ | ||
spec/*.js | ||
spec/*.map |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,14 @@ | ||
jspm_packages | ||
bower_components | ||
.idea | ||
.vscode | ||
.idea | ||
*.map | ||
doc/ | ||
spec/ | ||
.editorconfig | ||
circle.yml | ||
CONTRIBUTING.md | ||
gulpfile.js | ||
ISSUE_TEMPLATE.md | ||
tsconfig.json | ||
tsfmt.json | ||
tslint.json | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,28 @@ | ||
{ | ||
"version": "0.2.0", | ||
"configurations": [ | ||
{ | ||
"name": "Launch Tests", | ||
"type": "node", | ||
"request": "launch", | ||
"program": "${workspaceRoot}/node_modules/gulp/bin/gulp.js", | ||
"stopOnEntry": false, | ||
"args": [ | ||
"dev:debug" | ||
], | ||
"cwd": "${workspaceRoot}", | ||
"preLaunchTask": "dev:pre-debug", | ||
"internalConsoleOptions": "openOnSessionStart", | ||
"runtimeExecutable": null, | ||
"runtimeArgs": [ | ||
"--nolazy" | ||
], | ||
"env": { | ||
"NODE_ENV": "development" | ||
}, | ||
"externalConsole": false, | ||
"sourceMaps": true, | ||
"outDir": "${workspaceRoot}/dist" | ||
} | ||
] | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,9 @@ | ||
// Place your settings in this file to overwrite default and user settings. | ||
{ | ||
"files.exclude": { | ||
"**/*.map":true, | ||
"**/*.js": { | ||
"when": "$(basename).ts" | ||
} | ||
} | ||
} |
This file was deleted.
Oops, something went wrong.
This file was deleted.
Oops, something went wrong.
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,46 +1,13 @@ | ||
var path = require('path'); | ||
var fs = require('fs'); | ||
|
||
// hide warning // | ||
var emitter = require('events'); | ||
emitter.defaultMaxListeners = 20; | ||
|
||
var appRoot = 'src/'; | ||
var pkg = JSON.parse(fs.readFileSync('./package.json', 'utf-8')); | ||
|
||
var paths = { | ||
root: appRoot, | ||
source: appRoot + '**/*.js', | ||
html: appRoot + '**/*.html', | ||
style: 'styles/**/*.css', | ||
module.exports = { | ||
source: "src/", | ||
output: 'dist/', | ||
doc:'./doc', | ||
e2eSpecsSrc: 'test/e2e/src/*.js', | ||
e2eSpecsDist: 'test/e2e/dist/', | ||
doc:'doc/', | ||
packageName: pkg.name, | ||
specsSrc: 'test/**/*.spec.js', | ||
ignore: [], | ||
useTypeScriptForDTS: false, | ||
importsToAdd: [], | ||
sort: false | ||
spec: 'spec/', | ||
}; | ||
|
||
paths.files = [ | ||
'disposable.js', | ||
'dom.js', | ||
'feature.js', | ||
'global.js', | ||
'index.js', | ||
'nodejs-dom.js', | ||
'nodejs-feature.js', | ||
'nodejs-mutation-emulator.js', | ||
'nodejs-mutation-observer.js', | ||
'nodejs-platform.js', | ||
'observer.js', | ||
'performance.js', | ||
'platform.js' | ||
].map(function(file){ | ||
return paths.root + file; | ||
}); | ||
|
||
module.exports = paths; |
Oops, something went wrong.