Skip to content

Commit

Permalink
(feat): restore project to working state
Browse files Browse the repository at this point in the history
  • Loading branch information
MeirionHughes committed Oct 1, 2016
1 parent 08d90ab commit cce37af
Show file tree
Hide file tree
Showing 48 changed files with 617 additions and 1,260 deletions.
11 changes: 9 additions & 2 deletions .editorconfig
Original file line number Diff line number Diff line change
Expand Up @@ -5,10 +5,17 @@ root = true

# Unix-style newlines with a newline ending every file
[*]
indent_style = space
indent_size = 2
end_of_line = lf
insert_final_newline = true
charset = utf-8
trim_trailing_whitespace = false
insert_final_newline = false

[*.md]
trim_trailing_whitespace = false

# 2 space indentation
[**.*]
indent_style = space
indent_size = 2
indent_size = 2
7 changes: 0 additions & 7 deletions .eslintrc.json

This file was deleted.

File renamed without changes.
6 changes: 6 additions & 0 deletions .github/PULL_REQUEST_TEMPLATE.md
Original file line number Diff line number Diff line change
@@ -0,0 +1,6 @@
Make sure you check the following:
* [ ] unless trivial, a corresponding issue exists for this PR (reference it)
* [ ] if this PR fixes the issue, then include `fix #` and the issue number
* [ ] if this PR adds a feature, then you've included tests in `spec/`
* [ ] you've ran `gulp test` and it passes the lint and spec
* [ ] you've prepended the PR description i.e. (chore):, (feat):, (fix):
4 changes: 3 additions & 1 deletion .gitignore
Original file line number Diff line number Diff line change
@@ -1,6 +1,8 @@
node_modules
jspm_packages
bower_components
.idea
.DS_STORE
build/reports
dist/
spec/*.js
spec/*.map
17 changes: 14 additions & 3 deletions .npmignore
Original file line number Diff line number Diff line change
@@ -1,3 +1,14 @@
jspm_packages
bower_components
.idea
.vscode
.idea
*.map
doc/
spec/
.editorconfig
circle.yml
CONTRIBUTING.md
gulpfile.js
ISSUE_TEMPLATE.md
tsconfig.json
tsfmt.json
tslint.json

28 changes: 28 additions & 0 deletions .vscode/launch.json
Original file line number Diff line number Diff line change
@@ -0,0 +1,28 @@
{
"version": "0.2.0",
"configurations": [
{
"name": "Launch Tests",
"type": "node",
"request": "launch",
"program": "${workspaceRoot}/node_modules/gulp/bin/gulp.js",
"stopOnEntry": false,
"args": [
"dev:debug"
],
"cwd": "${workspaceRoot}",
"preLaunchTask": "dev:pre-debug",
"internalConsoleOptions": "openOnSessionStart",
"runtimeExecutable": null,
"runtimeArgs": [
"--nolazy"
],
"env": {
"NODE_ENV": "development"
},
"externalConsole": false,
"sourceMaps": true,
"outDir": "${workspaceRoot}/dist"
}
]
}
9 changes: 9 additions & 0 deletions .vscode/settings.json
Original file line number Diff line number Diff line change
@@ -0,0 +1,9 @@
// Place your settings in this file to overwrite default and user settings.
{
"files.exclude": {
"**/*.map":true,
"**/*.js": {
"when": "$(basename).ts"
}
}
}
25 changes: 0 additions & 25 deletions bower.json

This file was deleted.

74 changes: 0 additions & 74 deletions build/babel-options.js

This file was deleted.

41 changes: 4 additions & 37 deletions build/paths.js
Original file line number Diff line number Diff line change
@@ -1,46 +1,13 @@
var path = require('path');
var fs = require('fs');

// hide warning //
var emitter = require('events');
emitter.defaultMaxListeners = 20;

var appRoot = 'src/';
var pkg = JSON.parse(fs.readFileSync('./package.json', 'utf-8'));

var paths = {
root: appRoot,
source: appRoot + '**/*.js',
html: appRoot + '**/*.html',
style: 'styles/**/*.css',
module.exports = {
source: "src/",
output: 'dist/',
doc:'./doc',
e2eSpecsSrc: 'test/e2e/src/*.js',
e2eSpecsDist: 'test/e2e/dist/',
doc:'doc/',
packageName: pkg.name,
specsSrc: 'test/**/*.spec.js',
ignore: [],
useTypeScriptForDTS: false,
importsToAdd: [],
sort: false
spec: 'spec/',
};

paths.files = [
'disposable.js',
'dom.js',
'feature.js',
'global.js',
'index.js',
'nodejs-dom.js',
'nodejs-feature.js',
'nodejs-mutation-emulator.js',
'nodejs-mutation-observer.js',
'nodejs-platform.js',
'observer.js',
'performance.js',
'platform.js'
].map(function(file){
return paths.root + file;
});

module.exports = paths;
Loading

0 comments on commit cce37af

Please sign in to comment.