-
Notifications
You must be signed in to change notification settings - Fork 27
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
ZCS-13983:Replaced perl-net-libidn with perl-net-libidn2 for RHEL9
- Loading branch information
Showing
14 changed files
with
196 additions
and
1 deletion.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,65 @@ | ||
PKG_ROOT := $(shell pwd) | ||
|
||
include $(PKG_ROOT)/../../package.def | ||
|
||
pvers := $(NET_LIBIDN2) | ||
pname := Net-LibIDN2 | ||
pname_lc := net-libidn2 | ||
|
||
pfile := $(pname)-$(pvers).tar.gz | ||
psrc_file := $(SRC_DIR)/$(pfile) | ||
purl := https://cpan.metacpan.org/authors/id/T/TH/THOR/$(pfile) | ||
zname := zimbra-perl-$(pname_lc) | ||
zspec := $(pname_lc).spec | ||
|
||
.PHONY: all checkos clean build getsrc pkgadd pkgrm setup | ||
|
||
all: checkos clean getsrc build pkgrm1 | ||
|
||
checkos: | ||
ifneq ($(BUILD_PLATFORM), RHEL9_64) | ||
@echo "Skipping OS, not required" | ||
@exit 1 | ||
endif | ||
|
||
# $(@D) == directory part of the target | ||
getsrc: $(psrc_file) | ||
$(psrc_file): | ||
$(MKDIR) $(@D) && $(CD) $(@D) && $(WGET) $(purl) | ||
|
||
pkgadd: | ||
$(PKG_EXTRACT) zimbra-perl-base | ||
|
||
pkgrm: pkgrm% | ||
pkgrm%: | ||
$(PKG_PURGE) zimbra-base | ||
|
||
setup: | ||
$(generic-setup) | ||
|
||
build: setup pkgadd build_$(PKG_EXT) | ||
|
||
build_rpm: specfile = SPECS/$(zspec) | ||
build_rpm: | ||
$(CD) $(PLATFORM_DIR)/$(zname)/rpm && \ | ||
$(replace-pkginfo) $(specfile) && \ | ||
$(replace-pathinfo) $(specfile) && \ | ||
$(replace-perl-modinfo) $(specfile) && \ | ||
$(MKDIR) BUILD BUILDROOT RPMS SOURCES SRPMS && \ | ||
$(CP) $(psrc_file) SOURCES/$(zname)-$(pvers).tar.gz && \ | ||
$(PKG_BUILD) $(specfile) | ||
|
||
build_deb: z_tgz = $(zname)_$(pvers).orig.tar.gz | ||
build_deb: z_shlibs = $(subst $(zname)/,,$(wildcard $(zname)/debian/z*.shlibs)) | ||
build_deb: | ||
$(CD) $(PLATFORM_DIR)/$(zname) && \ | ||
$(replace-pkginfo) debian/changelog $(z_shlibs) && \ | ||
$(replace-pathinfo) debian/rules && \ | ||
$(replace-perl-modinfo) debian/changelog debian/control debian/copyright debian/watch && \ | ||
$(CP) $(psrc_file) ../$(z_tgz) && \ | ||
$(TAR) xfz ../$(z_tgz) --strip-components=1 --exclude=debian && \ | ||
$(CP) $(PKG_ROOT)/patches/*.patch debian/patches/ && \ | ||
$(PKG_BUILD) | ||
|
||
clean: pkgrm | ||
$(generic-clean) |
5 changes: 5 additions & 0 deletions
5
thirdparty/perl-net-libidn2/zimbra-perl-net-libidn2/debian/changelog
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,5 @@ | ||
zimbra-perl-MODNORMNAME (VERSION-ITERATIONZAPPEND) unstable; urgency=low | ||
|
||
* Initial Release. | ||
|
||
-- Zimbra Packaging Services <[email protected]> Wed, 9 Sep 2015 00:00:00 +0000 |
1 change: 1 addition & 0 deletions
1
thirdparty/perl-net-libidn2/zimbra-perl-net-libidn2/debian/compat
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
9 |
16 changes: 16 additions & 0 deletions
16
thirdparty/perl-net-libidn2/zimbra-perl-net-libidn2/debian/control
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,16 @@ | ||
Source: zimbra-perl-MODNORMNAME | ||
Section: perl | ||
Priority: optional | ||
Maintainer: Zimbra Packaging Services <[email protected]> | ||
Build-Depends: debhelper (>= 9), zimbra-perl-base, libidn2-dev | ||
Standards-Version: 3.9.5 | ||
Homepage: https://metacpan.org/release/MODNAME | ||
|
||
Package: zimbra-perl-MODNORMNAME | ||
Architecture: all | ||
Depends: ${misc:Depends}, ${perl:Depends}, ${shlibs:Depends}, zimbra-perl-base, | ||
libidn2 | ||
Description: Net::LibIDN - Perl bindings for GNU Libidn | ||
Provides bindings for GNU Libidn, a C library for handling | ||
Internationalized Domain Names according to IDNA (RFC 3490), | ||
in a way very much inspired by Turbo Fredriksson's PHP-IDN. |
37 changes: 37 additions & 0 deletions
37
thirdparty/perl-net-libidn2/zimbra-perl-net-libidn2/debian/copyright
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,37 @@ | ||
Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/ | ||
Source: https://metacpan.org/release/MODNAME | ||
Upstream-Contact: [email protected] | ||
Upstream-Name: MODNAME | ||
|
||
Files: * | ||
Copyright: 2003-2009, Thomas Jacob, Internet24.de | ||
License: Artistic or GPL-1+ | ||
|
||
Files: debian/* | ||
Copyright: 2015, Zimbra Packaging Services <[email protected]> | ||
License: GPL-2 | ||
|
||
License: Artistic | ||
This program is free software; you can redistribute it and/or modify | ||
it under the terms of the Artistic License, which comes with Perl. | ||
. | ||
On Debian systems, the complete text of the Artistic License can be | ||
found in `/usr/share/common-licenses/Artistic'. | ||
|
||
License: GPL-1+ | ||
This program is free software; you can redistribute it and/or modify | ||
it under the terms of the GNU General Public License as published by | ||
the Free Software Foundation; either version 1, or (at your option) | ||
any later version. | ||
. | ||
On Debian systems, the complete text of version 1 of the GNU General | ||
Public License can be found in `/usr/share/common-licenses/GPL-1'. | ||
|
||
License: GPL-2 | ||
This program is free software; you can redistribute it and/or modify | ||
it under the terms of the GNU General Public License as published by | ||
the Free Software Foundation; either version 2 of the License, or | ||
(at your option) any later version. | ||
. | ||
On Debian systems, the full text of the GNU General Public License | ||
version 2 can be found in `/usr/share/common-licenses/GPL-2'. |
Empty file.
26 changes: 26 additions & 0 deletions
26
thirdparty/perl-net-libidn2/zimbra-perl-net-libidn2/debian/rules
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,26 @@ | ||
#!/usr/bin/make -f | ||
|
||
%: | ||
dh $@ | ||
|
||
override_dh_auto_configure: | ||
perl -I OZCL/perl5 Build.PL INSTALL_BASE=OZC \ | ||
INSTALLSITEMAN1DIR=OZCS/man/man1 INSTALLSITEMAN3DIR=OZCS/man/man3 \ | ||
LIB=OZCL/perl5 | ||
|
||
# these need to know about our custom location for modules | ||
override_dh_perl: | ||
dh_perl OZCL/perl5 | ||
|
||
override_dh_auto_test: | ||
PERL5LIB=OZCL/perl5 dh_auto_test | ||
|
||
# remove .packlist and perllocal.pod | ||
# $(DESTINSTALLSITEARCH)/auto/$(FULLEXT)/.packlist | ||
# $(DESTINSTALLSITEARCH)/perllocal.pod | ||
PERL_ARCHNAME := $(shell perl -MConfig -e 'print $$Config{archname}') | ||
override_dh_auto_install: | ||
./Build install destdir=$(CURDIR)/debian/$(shell dh_listpackages)/OZCL/perl5/$(PERL_ARCHNAME) | ||
|
||
rm -f $(CURDIR)/debian/$(shell dh_listpackages)/OZCL/perl5/$(PERL_ARCHNAME)/perllocal.pod | ||
rm -f $(CURDIR)/debian/$(shell dh_listpackages)/OZCL/perl5/$(PERL_ARCHNAME)/auto/*/*/.packlist |
1 change: 1 addition & 0 deletions
1
thirdparty/perl-net-libidn2/zimbra-perl-net-libidn2/debian/source/format
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
3.0 (quilt) |
2 changes: 2 additions & 0 deletions
2
thirdparty/perl-net-libidn2/zimbra-perl-net-libidn2/debian/watch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,2 @@ | ||
version=3 | ||
https://metacpan.org/release/MODNAME .*/MODNAME-v?(\d[\d.-]*)\.(?:tar(?:\.gz|\.bz2)?|tgz)$ |
35 changes: 35 additions & 0 deletions
35
thirdparty/perl-net-libidn2/zimbra-perl-net-libidn2/rpm/SPECS/net-libidn2.spec
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,35 @@ | ||
Summary: Net::LibIDN2 - Perl bindings for GNU Libidn2 | ||
Name: zimbra-perl-MODNORMNAME | ||
Version: VERSION | ||
Release: 1zimbra10.0b1ZAPPEND | ||
License: GPL+ or Artistic | ||
Source: %{name}-%{version}.tar.gz | ||
Packager: Zimbra Packaging Services <[email protected]> | ||
Group: Development/Languages | ||
BuildRequires: zimbra-perl-base, libidn2-devel | ||
Requires: zimbra-perl-base, libidn2 | ||
Obsoletes: zimbra-perl-net-libidn | ||
AutoReqProv: no | ||
URL: https://metacpan.org/release/MODNAME | ||
|
||
%description | ||
Provides bindings for GNU Libidn2, a C library for handling internationalized domain names based on IDNA 2008, Punycode and TR46. | ||
|
||
%define debug_package %{nil} | ||
|
||
%prep | ||
%setup -n MODNAME-%{version} | ||
|
||
%build | ||
perl -I OZCL/perl5 Build.PL install_base=OZC --install_path libdoc=OZCS/man/man3 --install_path bindoc=OZCS/man/man1 | ||
PERL5LIB=OZCL/perl5 ./Build test | ||
|
||
%define perl_archname %(perl -MConfig -e 'print $Config{archname}') | ||
%install | ||
./Build install destdir=${RPM_BUILD_ROOT} | ||
rm -f %{buildroot}OZCL/perl5/%{perl_archname}/auto/*/*/.packlist | ||
|
||
%files | ||
%defattr(-,root,root) | ||
OZCL | ||
OZCS/man |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,3 @@ | ||
perldeps.RHEL9_64 := zimbra-perl-net-libidn2 | ||
perldeps.RHEL8_64 := zimbra-perl-net-libidn | ||
perldeps.RHEL7_64 := zimbra-perl-net-libidn |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters