Skip to content

Commit

Permalink
chore(sync): um40 → um41 (#42)
Browse files Browse the repository at this point in the history
* Fix copr vendor distribution

Fixes a small typo in the COPR vendor distribution name, which was apparently case-sensitive
and causing COPR imports to fail due to the plugin (especially DNF5) expecting "fedora" (lowercase)
instead of "Fedora" (uppercase).

Signed-off-by: madonuko <[email protected]>

* feat(ci): update.yml and also upgrade to actions v4 (#34)

---------

Signed-off-by: madonuko <[email protected]>
Co-authored-by: Cappy Ishihara <[email protected]>
  • Loading branch information
madonuko and korewaChino authored Aug 11, 2024
1 parent ff97f9b commit 3de2e08
Show file tree
Hide file tree
Showing 3 changed files with 57 additions and 4 deletions.
4 changes: 2 additions & 2 deletions .github/workflows/autobuild.yml
Original file line number Diff line number Diff line change
Expand Up @@ -25,7 +25,7 @@ jobs:
- name: Set workspace as safe
run: git config --global --add safe.directory "$GITHUB_WORKSPACE"
- name: Checkout
uses: actions/checkout@v3
uses: actions/checkout@v4
with:
fetch-depth: 0
- name: Generate build matrix
Expand All @@ -52,7 +52,7 @@ jobs:

- name: Cache buildroot
id: br-cache
uses: actions/cache@v3
uses: actions/cache@v4
with:
path: /var/cache
key: ${{ runner.os }}-br-${{ matrix.version }}-${{ matrix.pkg.arch }}
Expand Down
53 changes: 53 additions & 0 deletions .github/workflows/update.yml
Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
name: Update
on:
schedule:
- cron: "0 * * * *"
workflow_dispatch:

jobs:
autoupdate:
runs-on: ubuntu-latest
container:
image: ghcr.io/terrapkg/builder:frawhide
options: --cap-add=SYS_ADMIN --privileged
steps:
- name: Checkout
uses: actions/checkout@v4
with:
fetch-depth: 0
ssh-key: ${{ secrets.SSH_AUTHENTICATION_KEY }}

- name: Install SSH signing key & Set up git repository
run: |
mkdir -p ${{ runner.temp }}
echo "${{ secrets.SSH_SIGNING_KEY }}" > ${{ runner.temp }}/signing_key
chmod 0700 ${{ runner.temp }}/signing_key
git config --global --add safe.directory "$GITHUB_WORKSPACE"
- name: Run Update
run: anda update -vv
env:
GITHUB_TOKEN: ${{ secrets.GITHUB_TOKEN }}
RUST_BACKTRACE: full

- name: Save
run: |
if [[ `git status --porcelain` ]]; then
git config user.name "Raboneko"
git config user.email "[email protected]"
git config gpg.format "ssh"
git config user.signingkey "${{ runner.temp }}/signing_key"
msg="bump: $(git status | grep modified | sed -r 's@.+/([^/]+)/[^/]+\n?@\1 @g' | tr -d '\n')"
git commit -S -a -m "$msg"
copy_over () {
git format-patch HEAD^
git checkout $1
git apply *.patch || true
rm *.patch
git add *
git commit -S -a -m "$msg"
}
copy_over um39 || true
copy_over um40 || true
git push -u origin --all
fi
4 changes: 2 additions & 2 deletions ultramarine/release/ultramarine-release.spec
Original file line number Diff line number Diff line change
Expand Up @@ -45,7 +45,7 @@
Summary: Ultramarine Linux release files
Name: ultramarine-release
Version: %{dist_version}
Release: 10%{?dist}
Release: 11%{?dist}
License: MIT
Source0: LICENSE
URL: https://ultramarine-linux.org
Expand Down Expand Up @@ -828,7 +828,7 @@ sed -e "s#\$version#%{bug_version}#g" -e 's/$edition/Atomic XFCE/;s/<!--.*-->//;
install -d %{buildroot}%{_datadir}/dnf/plugins
cat >> %{buildroot}%{_datadir}/dnf/plugins/copr.vendor.conf << EOF
[main]
distribution = Fedora
distribution = fedora
releasever = %{releasever}
EOF

Expand Down

0 comments on commit 3de2e08

Please sign in to comment.