Skip to content

Commit

Permalink
graphviz: Avoid lock_t.
Browse files Browse the repository at this point in the history
  • Loading branch information
jperkin committed Dec 2, 2024
1 parent 396e937 commit b0da5aa
Show file tree
Hide file tree
Showing 3 changed files with 38 additions and 1 deletion.
4 changes: 3 additions & 1 deletion graphics/graphviz/distinfo
Original file line number Diff line number Diff line change
@@ -1,9 +1,11 @@
$NetBSD: distinfo,v 1.88 2024/11/18 13:59:28 micha Exp $
$NetBSD: distinfo,v 1.89 2024/12/02 16:02:30 jperkin Exp $

BLAKE2s (graphviz-12.2.0.tar.gz) = e7ab7167a5af792de92dd33048a4a2b8b366a6850b4a7a7ce831151b31e8af16
SHA512 (graphviz-12.2.0.tar.gz) = d7c73aca3ccbce0327f48c58fa54b76be84140fc8ab99b91eb595b917f1ff89172aa868705df2d1bd50dc75328be824455cd9f6cf079dbb1269c40af9966d418
Size (graphviz-12.2.0.tar.gz) = 26813735 bytes
SHA1 (patch-config_config__perl.pl) = 430acb7d7ee3e149de0af9832c5a29602884f83e
SHA1 (patch-configure.ac) = dcb9fd2822d3eb5dddcda5a55746d51114f92d06
SHA1 (patch-lib_gvc_Makefile.am) = 8a25c16a31923fc42138773f308f3b3fc5ee662b
SHA1 (patch-lib_gvpr_actions.c) = d82023aa576ed4404e3a123ee063d58228ec2ea6
SHA1 (patch-lib_gvpr_compile.h) = 5cf479c021783f74fc7e886faf1c0cf5b8e721de
SHA1 (patch-plugin_gs_gvloadimage__gs.c) = 982ac1db252e3224633069db956c5dc803cd5ea9
15 changes: 15 additions & 0 deletions graphics/graphviz/patches/patch-lib_gvpr_actions.c
Original file line number Diff line number Diff line change
@@ -0,0 +1,15 @@
$NetBSD: patch-lib_gvpr_actions.c,v 1.1 2024/12/02 16:02:30 jperkin Exp $

Avoid lock_t.

--- lib/gvpr/actions.c.orig 2024-12-02 15:59:23.387253475 +0000
+++ lib/gvpr/actions.c
@@ -502,7 +502,7 @@ int lockGraph(Agraph_t *g, int v) {
if (data->lock.zombie)
agclose(g);
else
- data->lock = (lock_t){0};
+ data->lock = (gvprlock_t){0};
}
return oldv;
}
20 changes: 20 additions & 0 deletions graphics/graphviz/patches/patch-lib_gvpr_compile.h
Original file line number Diff line number Diff line change
@@ -0,0 +1,20 @@
$NetBSD: patch-lib_gvpr_compile.h,v 1.1 2024/12/02 16:02:30 jperkin Exp $

Avoid lock_t.

--- lib/gvpr/compile.h.orig 2024-12-02 15:58:56.601986844 +0000
+++ lib/gvpr/compile.h
@@ -38,11 +38,11 @@ extern "C" {
typedef struct {
bool locked: 1; ///< is the lock currently taken?
bool zombie: 1; ///< was a deletion request recorded while locked?
-} lock_t;
+} gvprlock_t;

typedef struct {
Agrec_t h;
- lock_t lock;
+ gvprlock_t lock;
} gval_t;

typedef struct {

0 comments on commit b0da5aa

Please sign in to comment.