Skip to content

Commit

Permalink
(..geography/R-stars) Updated 0.5.3 to -l.6.7
Browse files Browse the repository at this point in the history
# version 0.6-7

* `st_extract()` fix if points coincide with boundary grid cell centers and bilinear interpolation is used; #720

* `st_extract()` if used with GDAL 3.10.0 uses InterpolateAtPoints, allowing for cubic and cubicspline interpolators (requiring sf >= 1.0-19).

* `Ops.stars()` (math ops) now also recycle arrays in the first argument; #718

* `c.stars()` verifies semantic equivalence of objects' CRS; #703

* initial support for `read_mdim()` to work with `proxy = TRUE`; #659

# version 0.6-6

* skip `cubble` tests for cubble version 0.3.1; huizezhang-sherry/cubble#30

* `st_transform.stars` transforms geometries in array elements

* `mutate.stars` (and others) handle attribute names with spaces in them; #689

* `st_crop()` gains an argument `normalize`; when set to `TRUE` `st_normalize()` is called on the returned value; #685, #686

* constrain reading full GEOLOCATION arrays to the case where they are 2-D; #678

# version 0.6-5

* fix `st_as_stars.Spatial()` for `Spatial` gridded objects with non-square grid cells, see r-spatial/gstat#123

* add `prcomp()` methods for `stars` and `stars_proxy` objects, working on attributes or last dimension

* `st_rasterize()` with `align=TRUE` returns `NA` values where there are no data; #668

* `read_mdim()` reads tables with composity type, returning a `data.frame` in that case; #659

* `st_rotate()` transforms a rotated grid back to a curvilinear grid in unrotated coordinates.

* `aggregate.stars()` deals with functions that return more than one number, putting these in a new dimension like `st_apply()` does

* `st_as_stars.data.frame()` and `st_as_stars.sf()` better handle non-raster data cubes

* `plot.stars()` only resets layout when needed (more than one sub-plot, or key present)

* fixed `st_as_stars.im()`; #648

* `st_crs<-.stars()` is less critical on existing CRS being of class `crs`

* `c.stars()` with a single (valid) argument and `along` specified adds a dimension; #646

* `st_join.stars()` keeps attributes from `x` complete; #643

* `st_as_stars.list()` requires a _named_ list, and will set names of array dimensions if not present

# version 0.6-4

* `plot.stars()` has a `fill` argument that shifts unused plotting space between sub-maps to the bottom or right side of the plotting area

* in `plot.stars()`, the `key.width` default is sensitive to `par("ps")`, the pointsize graphics parameter

* `plot.stars()` and `image.stars()` are sensitive to `cex.axis`, for axes and key (requires sf >= 1.0-14); #642

* move `lwgeom` dependency to Suggests; using `st_transform_proj()` on vector data cubes requires loading `lwgeom` first

# version 0.6-3

* `st_downsample()` has argument `offset` to pixel-shift downsampled images

* `st_downsample()` has argument `FUN` to compute sub-tile aggregates; #604

* `st_as_stars.bbox()` retains `factor` values; #640

* fix CRAN error in test script

* `st_crop()` works (and warns) for the case when the crop area does not overlap with the area of the object; #638

# version 0.6-2

* `split.stars()` accepts `stars` objects with multiple attributes; #635

* `[.stars()` supports `NA` values in dimension ranges for vector geometry (`sfc`) dimensions, resulting in empty geometries

* `st_extract()` supports extracting points values from curvilinear grids (when not proxy); #632

* `read_mdim()` reads curvilinear rasters (geolocation arrays), so far only at full extent/resolution

* `st_as_stars.stars()` accepts curvilinear argument with lon/lat array names present in `.x`

* consistently use `OGC:CRS84` instead of `EPSG:4326`

* setting `values = NULL` in `st_set_dimensions()` removes dimension values

* more gracefully handle plotting of global coverage curvilinear grids; #632

* `image.stars()` plots images (e.g. of cross sections) when x and/or y are singular or absent; #628

* `st_as_stars.cubble_df()` adds conversion from cubble; `cubble::as_cubble()` methods converts back

* `[<-.stars()` accepts for `i` an indicator (numeric length character) to the array to be replaced; #626

* `plot.stars()` gains an argument `key.lab` to set the legend key label (requires sf >= 1.0-13)

# version 0.6-1

* remove `rgdal` dependency

* `read_stars()` fixes combining bands with different block sizes; #623

* `st_warp()` gets (proper) default value for `threshold`; #618

* `read_mdim()` reads "raster" with single pixel (as a point)

* `[.stars()`, as in `r[x]` allows `x` to be a logical stars object

* `[<-.stars_proxy()` clones environment, so that after `r[r > 100] = NA` we don't get infinite recursion when realizing `r`

* `read_stars()` avoids reading a raster twice to determine how to choose `proxy`; `proxy` can now be set as (and defaults to) the number of cells (bands * rows * columns) above which data will not be read in memory but returned as `stars_proxy` object; #609

* fix using `RasterIO` in `read_stars()` when `proxy=TRUE`; #608

* `plot.stars()` hook function can handle arguments `row`, `col`, `nrow`, `ncol`, `nr`, `value` and `bbox`; #600

* fix handling of categorical rasters with colors but without category labels; #595, fallout of #565

* fix subsetting of proxy objects over a time range; #596

# version 0.6-0

* `write_stars()` writes scaled and/or shifted values when using argument `scale_offset`; #589

* `aggregate.stars_proxy()` implements aggregation with non-spatial `by` objects (lazily)

* fix `[.stars_proxy()` when selecting dimension 3 and higher; #561

* in `plot.stars()`, `col` can also be a palette function

* `st_res()` returns spatial resolutions, and optionally all dimension resolutions; #557 thanks to Krzysztof Dyba

* `read_stars()` shortens band or array names that contain a common start or ending, unless names would become empty or `shorten=FALSE` was set; e.g. `shorten="B"` puts a `B` before shortened array names

* printing `stars` dimension tables omits fields with only `NULL` or `NA` values, unless `print(..., all = TRUE)` is given

* improve reading categorical rasters, which now avoids calling `factor()`; #565 thanks to Krzysztof Dyba

* `read_mdim()` will read bounds arrays for coordinates using the `bounds` attribute, and accepts a `bounds` argument to specify them when that attribute is missing

* `time()` returns time stamps of a time dimension

* `st_cells()` returns the cell index for a set of point coordinates, provided as `sf` or `sfc` object; #558

* reading & writing vector data cubes: `read_mdim()` reads CF compliant vector geometries, and reconstructs them into an `sfc` dimension; `write_mdim()` writes them.

* `write_mdim()` uses GDAL multidimensional array API;

* `read_mdim()` uses arguments `offset`, `count` and `step` to read sub-arrays or strided arrays (requires sf >= 1.0-9)

# version 0.5-6

* export `read_mdim()`, a reader using GDAL's multidimensional array API (for sf <= 1.0-8)

* remove `tos_O1_2001-2002.nc` from packaged datasets to keep source package size below 5 Mb

* `as.POSIXct.stars()` converts `PCICt` dimensions to `POSIXct` values.

* improve handling of `PCICt` 360 or 365 day calendars; read them in `read_mdim` (requires sf >= 1.0-9)

* `read_stars()` reads factor levels better from attribute table; #484 thanks to @ailich

* `read_stars()` puts band names from `band_meta` DESCRIPTION= tags into `values`;

* improve handling of categorical rasters, and their exchange with `terra`; #484

* `plot()` handles auto colors better for factor arrays

* `read_ncdf()` handles units more formally in setting crs; #533

* print message that dimensions of proxy objects do not reflect unevaluated operations; #530

* passing `na.action = na.omit` to `geom_stars()` removes `NA` values; #532

* `read_stars()` detects curvilinear grids automatically; #513

* `st_warp()` warps curvilinear grids (using Euclidean distances only on coordinates); #513

* `Ops.stars()` errors when (common) dimension are not identical; #506

* `guess_raster()` accepts empty rows/columns and sparse grids; #509

* speed up `rgb` plotting; #503

* Added a new helper function `st_tile()` to specify the block
  parameters (`nXOff`, `nYOff`, `nXsize`, `nYSize`) required by `RasterIO`
  argument in `read_stars()`; #492 thanks to Krzysztof Dyba

# version 0.5-5

* `st_as_stars.bbox()` creates an empy raster file if `proxy = TRUE`; #489

* `st_rasterize()` has option `align = TRUE` to use a template for aligning the new raster to; #489

* `adrop.stars()` with missing dimensions no longer drops x/y raster dimensions; #485

* `aggregate.stars()` propagates units of arrays; #477

# version 0.5-4

* `c.stars()` fails if it tries to merge arrays with different units; #475

* For NetCDF files, `read_stars()` uses the `long_name` as array name; #475

* add `rename()` method; #470

* refresh CRS of packaged `L7_ETMs.tif`; #466

* `as.data.frame.stars()` works for mixed regular and rectilinear dimension; #458

* `plot.stars()` plots curvilinear rasters with color table, or without table but `col` argument passed; #456

* `st_extract()` accepts a matrix with points as `at` argument, for when performance is important; see e.g. rspatial/terra#341

* fix bug in `st_crop()` when cropping area is larger than grid; #455

* export `st_downsample()`, e.g. to be used by `tmap`; r-tmap/tmap#597

* argument `downsample` in `plot.stars()` and `st_as_stars.stars_proxy()` and `st_downsample()` has the same effect (removed a one-offset between them).

* `st_redimension()` works for curvilinear grids; #441

* `downsample` is propagated to subexpressions like `r[r < 50] = NA`

* `predict.stars()` obtains an argument `drop_dimensions` that, if `TRUE`, drops dimensions from the prediction `data.frame`; #362

* extend options in `st_rgb()`, #432, by Gabo Gaona

* allow subsetting with `[` by using labels, e.g. of band names.
  • Loading branch information
mef committed Dec 1, 2024
1 parent 24c7dbd commit 6c83ca7
Show file tree
Hide file tree
Showing 2 changed files with 10 additions and 9 deletions.
11 changes: 6 additions & 5 deletions geography/R-stars/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.2 2021/09/20 13:01:32 mef Exp $
# $NetBSD: Makefile,v 1.3 2024/12/01 14:52:54 mef Exp $

R_PKGNAME= stars
R_PKGVER= 0.5-3
R_PKGVER= 0.6-7
CATEGORIES= geography

MAINTAINER= [email protected]
Expand All @@ -15,10 +15,11 @@ DEPENDS+= R-abind>=1.4.5:../../math/R-abind
DEPENDS+= R-units>=0.6.5:../../math/R-units

# Packages suggested but not available:
# 'PCICt', 'clue', 'cubelyr', 'exactextractr', 'future.apply',
# 'ggforce', 'ncdfgeom', 'ncmeta', 'pbapply', 'plm', 'starsdata',
# 'terra'
# 'OpenStreetMap', 'PCICt', 'clue', 'cubble', 'cubelyr',
# 'exactextractr', 'future.apply', 'ggforce', 'ncdfgeom', 'ncmeta',
# 'pbapply', 'plm', 'starsdata', 'tsibble'

TEST_DEPENDS+= R-Cairo-[0-9]*:../../graphics/R-Cairo
TEST_DEPENDS+= R-RNetCDF-[0-9]*:../../math/R-RNetCDF
TEST_DEPENDS+= R-covr-[0-9]*:../../devel/R-covr
TEST_DEPENDS+= R-digest-[0-9]*:../../security/R-digest
Expand Down
8 changes: 4 additions & 4 deletions geography/R-stars/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.4 2021/10/26 10:45:08 nia Exp $
$NetBSD: distinfo,v 1.5 2024/12/01 14:52:54 mef Exp $

BLAKE2s (R/stars_0.5-3.tar.gz) = 1b75543d10e6b8dcf7a19e419a2d7a9501439adfd133367322052fc47e701c7f
SHA512 (R/stars_0.5-3.tar.gz) = 158b028f982ca2610c7935635f93bb76b2123eec08b27fe3b6a981ac202cfe3cd0a6749cb307d26e7ba47bece756cbcdafc02c7ff69791f18e9fc0b879cee419
Size (R/stars_0.5-3.tar.gz) = 5047525 bytes
BLAKE2s (R/stars_0.6-7.tar.gz) = aa4df6ca1d867a6850360df46db58282f31423534e9a952e343fc45eacdc2aa7
SHA512 (R/stars_0.6-7.tar.gz) = e4487c9bc2b6f03a5d9bbb478c8e626dfdf7e62de1ea1910679375226bca3f6e927fc425883c0e22e333a34a8b21855817cf7f0f3276919fcd5a1fc2308218f0
Size (R/stars_0.6-7.tar.gz) = 4033515 bytes

0 comments on commit 6c83ca7

Please sign in to comment.