You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
For some reason, the __ prefix is unacceptable for iOS developers in our team (it breaks code rules style). I would like to ask for a customization option for coroutine functions.
Current:
class B: A {
override func __foo() async throws -> KotlinInt {
return KotlinInt(1)
}
}
Proposition:
Gradle:
skie {
features {
coroutinesInteropPrefix.set("suspend")
}
}
Code:
class B: A {
override func suspendfoo() async throws -> KotlinInt {
return KotlinInt(1)
}
}
reacted with thumbs up emoji reacted with thumbs down emoji reacted with laugh emoji reacted with hooray emoji reacted with confused emoji reacted with heart emoji reacted with rocket emoji reacted with eyes emoji
-
For some reason, the
__
prefix is unacceptable for iOS developers in our team (it breaks code rules style). I would like to ask for a customization option for coroutine functions.Current:
Proposition:
Gradle:
Code:
Beta Was this translation helpful? Give feedback.
All reactions