-
Notifications
You must be signed in to change notification settings - Fork 134
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
meta-xilinx-standalone: Rework embeddedsw integration
Introduce a new embeddedsw-source recipe that is a single point for unpack, and patch of the sources. This will allow someone to universally patch (via a bbappend or similar) the esw sources. As part of this work, we transfered the various patches for fsbl, pmu, plm, and psm to the universe source recipe. Most of this is transparent to any recipe using xlnx-embeddedsw. The class automaticaly detects if the recipe is a user our the special embeddedsw-source recipe and enables the correct behavior. Since the esw sources expect the S and B to be the same, the cmake objects get written into S, we are not able to follow the gcc-source example. Instead recipes that use the xlnx-embeddedsw class will hard link or copy the source files to their working directory. This avoid the penalty for fetch, unpack and patch. Note these recipes may also add their own SRC_URI which WILL be processed as normal. This is often used to introduce special tcl scripts. See the do_copy_shared_src task injected by the xlnx-embeddedsw.bbclass for technical details. Additionally, correct some of the existing patch Upstream-Status entries to conform to current YP guidelines. For 2024.2 introduce a special Xil_Assert fix for the current toolchain which is more strict on type conversion.. See the patch itself for more details. Signed-off-by: Mark Hatle <[email protected]>
- Loading branch information
Showing
48 changed files
with
169 additions
and
158 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
3 changes: 0 additions & 3 deletions
3
meta-xilinx-standalone-sdt/recipes-bsp/embeddedsw/esw-conf_2024.1.bb
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
3 changes: 0 additions & 3 deletions
3
meta-xilinx-standalone-sdt/recipes-bsp/embeddedsw/esw-conf_2024.2.bb
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
33 changes: 33 additions & 0 deletions
33
meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw-source.inc
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,33 @@ | ||
deltask do_configure | ||
deltask do_compile | ||
deltask do_install | ||
deltask do_populate_sysroot | ||
deltask do_populate_lic | ||
RM_WORK_EXCLUDE += "${PN}" | ||
|
||
inherit xlnx-embeddedsw nopackages | ||
|
||
COMPATIBLE_HOST = ".*" | ||
COMPATIBLE_MACHINE = ".*" | ||
|
||
PN = "embeddedsw-source-${PV}" | ||
WORKDIR = "${TMPDIR}/work-shared/embeddedsw-${PV}-${PR}" | ||
SSTATE_SWSPEC = "sstate:embeddedsw::${PV}:${PR}::${SSTATE_VERSION}:" | ||
|
||
STAMP = "${STAMPS_DIR}/work-shared/embeddedsw-${PV}-${PR}" | ||
STAMPCLEAN = "${STAMPS_DIR}/work-shared/embeddedsw-${PV}-*" | ||
|
||
INHIBIT_DEFAULT_DEPS = "1" | ||
DEPENDS = "" | ||
PACKAGES = "" | ||
TARGET_ARCH = "allarch" | ||
TARGET_AS_ARCH = "none" | ||
TARGET_CC_ARCH = "none" | ||
TARGET_LD_ARCH = "none" | ||
TARGET_OS = "linux" | ||
baselib = "lib" | ||
PACKAGE_ARCH = "all" | ||
|
||
UNPACKDIR = "${WORKDIR}/source" | ||
S = "${SHARED_S}" | ||
B = "${WORKDIR}/build" |
17 changes: 17 additions & 0 deletions
17
meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw-source_2023.1.bb
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,17 @@ | ||
require recipes-bsp/embeddedsw/embeddedsw-source.inc | ||
|
||
|
||
BPN = "embeddedsw-source" | ||
EXCLUDE_FROM_WORLD = "1" | ||
|
||
FILESPATH .= ":${FILE_DIRNAME}/embeddedsw/${PV}:${FILE_DIRNAME}/embeddedsw" | ||
|
||
SRC_URI = " \ | ||
${EMBEDDEDSW_SRCURI} \ | ||
file://makefile-skip-copy_bsp.sh.patch \ | ||
file://fsbl-fixups.patch \ | ||
file://0001-versal_fw-Fixup-core-makefiles.patch \ | ||
" | ||
|
||
# file://fix-xil-assert-filename.patch \ | ||
# |
17 changes: 17 additions & 0 deletions
17
meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw-source_2023.2.bb
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,17 @@ | ||
require recipes-bsp/embeddedsw/embeddedsw-source.inc | ||
|
||
|
||
BPN = "embeddedsw-source" | ||
EXCLUDE_FROM_WORLD = "1" | ||
|
||
FILESPATH .= ":${FILE_DIRNAME}/embeddedsw/${PV}:${FILE_DIRNAME}/embeddedsw" | ||
|
||
SRC_URI = " \ | ||
${EMBEDDEDSW_SRCURI} \ | ||
file://makefile-skip-copy_bsp.sh.patch \ | ||
file://fsbl-fixups.patch \ | ||
file://0001-versal_fw-Fixup-core-makefiles.patch \ | ||
" | ||
|
||
# file://fix-xil-assert-filename.patch \ | ||
# |
17 changes: 17 additions & 0 deletions
17
meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw-source_2024.1.bb
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,17 @@ | ||
require recipes-bsp/embeddedsw/embeddedsw-source.inc | ||
|
||
|
||
BPN = "embeddedsw-source" | ||
EXCLUDE_FROM_WORLD = "1" | ||
|
||
FILESPATH .= ":${FILE_DIRNAME}/embeddedsw/${PV}:${FILE_DIRNAME}/embeddedsw" | ||
|
||
SRC_URI = " \ | ||
${EMBEDDEDSW_SRCURI} \ | ||
file://makefile-skip-copy_bsp.sh.patch \ | ||
file://fsbl-fixups.patch \ | ||
file://0001-versal_fw-Fixup-core-makefiles.patch \ | ||
" | ||
|
||
# file://fix-xil-assert-filename.patch \ | ||
# |
15 changes: 15 additions & 0 deletions
15
meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw-source_2024.2.bb
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,15 @@ | ||
require recipes-bsp/embeddedsw/embeddedsw-source.inc | ||
|
||
|
||
BPN = "embeddedsw-source" | ||
EXCLUDE_FROM_WORLD = "1" | ||
|
||
FILESPATH .= ":${FILE_DIRNAME}/embeddedsw/${PV}:${FILE_DIRNAME}/embeddedsw" | ||
|
||
SRC_URI = " \ | ||
${EMBEDDEDSW_SRCURI} \ | ||
file://fix-xil-assert-filename.patch \ | ||
file://makefile-skip-copy_bsp.sh.patch \ | ||
file://fsbl-fixups.patch \ | ||
file://0001-versal_fw-Fixup-core-makefiles.patch \ | ||
" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -8,6 +8,8 @@ additional variables that may not be appropriate to do on the regular | |
command line build version. This patch preserves the default while | ||
allowing it to be overriden as necessary. | ||
|
||
Upstream-Status: Inappropriate [YP integration specific] | ||
|
||
Signed-off-by: Mark Hatle <[email protected]> | ||
--- | ||
lib/sw_apps/versal_plm/misc/versal/Makefile | 6 ++++-- | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -6,7 +6,7 @@ Subject: [PATCH] Prevent makefile from calling copy_bsp.sh | |
If we call copy_bsp.sh we will undo any manual compliation steps we | ||
have already done. Avoid this. | ||
|
||
YP integration specific | ||
Upstream-Status: Inappropriate [YP integration specific] | ||
|
||
Signed-off-by: Mark Hatle <[email protected]> | ||
--- | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -8,6 +8,8 @@ additional variables that may not be appropriate to do on the regular | |
command line build version. This patch preserves the default while | ||
allowing it to be overriden as necessary. | ||
|
||
Upstream-Status: Inappropriate [YP integration specific] | ||
|
||
Signed-off-by: Mark Hatle <[email protected]> | ||
--- | ||
lib/sw_apps/versal_plm/misc/versal/Makefile | 6 ++++-- | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -6,7 +6,7 @@ Subject: [PATCH] Prevent makefile from calling copy_bsp.sh | |
If we call copy_bsp.sh we will undo any manual compliation steps we | ||
have already done. Avoid this. | ||
|
||
YP integration specific | ||
Upstream-Status: Inappropriate [YP integration specific] | ||
|
||
Signed-off-by: Mark Hatle <[email protected]> | ||
--- | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -8,6 +8,8 @@ additional variables that may not be appropriate to do on the regular | |
command line build version. This patch preserves the default while | ||
allowing it to be overriden as necessary. | ||
|
||
Upstream-Status: Inappropriate [YP integration specific] | ||
|
||
Signed-off-by: Mark Hatle <[email protected]> | ||
--- | ||
lib/sw_apps/versal_plm/misc/versal/Makefile | 6 ++++-- | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -6,7 +6,7 @@ Subject: [PATCH] Prevent makefile from calling copy_bsp.sh | |
If we call copy_bsp.sh we will undo any manual compliation steps we | ||
have already done. Avoid this. | ||
|
||
YP integration specific | ||
Upstream-Status: Inappropriate [YP integration specific] | ||
|
||
Signed-off-by: Mark Hatle <[email protected]> | ||
--- | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -8,6 +8,8 @@ additional variables that may not be appropriate to do on the regular | |
command line build version. This patch preserves the default while | ||
allowing it to be overriden as necessary. | ||
|
||
Upstream-Status: Pending | ||
|
||
Signed-off-by: Mark Hatle <[email protected]> | ||
--- | ||
lib/sw_apps/versal_plm/misc/versal/Makefile | 6 ++++-- | ||
|
26 changes: 26 additions & 0 deletions
26
...inx-standalone/recipes-bsp/embeddedsw/embeddedsw/2024.2+git/fix-xil-assert-filename.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,26 @@ | ||
Fix __FILENAME__ definition | ||
|
||
This fixes the error: | ||
|
||
| <command-line>: error: passing argument 1 of 'Xil_Assert' makes pointer from integer without a cast [-Wint-conversion] | ||
| .../work-shared/embeddedsw-2024.2+git-r0/source/git/lib/bsp/standalone/src/common/xil_assert.h:123:20: note: in expansion of macro '__FILENAME__' | ||
| 123 | Xil_Assert(__FILENAME__, __LINE__); \ | ||
| | ^~~~~~~~~~~~ | ||
|
||
Upstream-Status: Pending | ||
|
||
Signed-off-by: Mark Hatle <[email protected]> | ||
|
||
diff --git a/cmake/Findcommon.cmake b/cmake/Findcommon.cmake | ||
index c856d408fb..acac2e8fcc 100644 | ||
--- a/cmake/Findcommon.cmake | ||
+++ b/cmake/Findcommon.cmake | ||
@@ -11,7 +11,7 @@ endif() | ||
if("${CMAKE_HOST_NAME}" STREQUAL "Linux") | ||
add_compile_options("-D__FILENAME__=\"$(subst ${CMAKE_SOURCE_DIR}/,,$(abspath $<))\"") | ||
else() | ||
- add_compile_options("-D__FILENAME__='__FILE__'") | ||
+ add_compile_options("-D__FILENAME__=__FILE__") | ||
endif() | ||
set (CMAKE_INSTALL_LIBDIR "lib") | ||
function (collector_create name base) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -6,7 +6,7 @@ Subject: [PATCH] Prevent makefile from calling copy_bsp.sh | |
If we call copy_bsp.sh we will undo any manual compliation steps we | ||
have already done. Avoid this. | ||
|
||
YP integration specific | ||
Upstream-Status: Inappropriate [YP integration specific] | ||
|
||
Signed-off-by: Mark Hatle <[email protected]> | ||
--- | ||
|
2 changes: 2 additions & 0 deletions
2
meta-xilinx-standalone/recipes-bsp/embeddedsw/embeddedsw/fsbl-fixups.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
7 changes: 0 additions & 7 deletions
7
meta-xilinx-standalone/recipes-bsp/embeddedsw/fsbl-firmware_2023.1+git-generic.inc
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,10 +1,3 @@ | ||
SKIP_MSG = "" | ||
SKIP_MSG:zynq = "Generic support for zynq is not available" | ||
SKIP_RECIPE[fsbl-firmware] = "${SKIP_MSG}" | ||
|
||
FILESPATH .= ":${FILE_DIRNAME}/embeddedsw/${PV}:${FILE_DIRNAME}/embeddedsw" | ||
|
||
SRC_URI += " \ | ||
file://makefile-skip-copy_bsp.sh.patch \ | ||
file://fsbl-fixups.patch \ | ||
" |
7 changes: 0 additions & 7 deletions
7
meta-xilinx-standalone/recipes-bsp/embeddedsw/fsbl-firmware_2023.2+git-generic.inc
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,10 +1,3 @@ | ||
SKIP_MSG = "" | ||
SKIP_MSG:zynq = "Generic support for zynq is not available" | ||
SKIP_RECIPE[fsbl-firmware] = "${SKIP_MSG}" | ||
|
||
FILESPATH .= ":${FILE_DIRNAME}/embeddedsw/${PV}:${FILE_DIRNAME}/embeddedsw" | ||
|
||
SRC_URI += " \ | ||
file://makefile-skip-copy_bsp.sh.patch \ | ||
file://fsbl-fixups.patch \ | ||
" |
7 changes: 0 additions & 7 deletions
7
meta-xilinx-standalone/recipes-bsp/embeddedsw/fsbl-firmware_2024.1+git-generic.inc
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,10 +1,3 @@ | ||
SKIP_MSG = "" | ||
SKIP_MSG:zynq = "Generic support for zynq is not available" | ||
SKIP_RECIPE[fsbl-firmware] = "${SKIP_MSG}" | ||
|
||
FILESPATH .= ":${FILE_DIRNAME}/embeddedsw/${PV}:${FILE_DIRNAME}/embeddedsw" | ||
|
||
SRC_URI += " \ | ||
file://makefile-skip-copy_bsp.sh.patch \ | ||
file://fsbl-fixups.patch \ | ||
" |
7 changes: 0 additions & 7 deletions
7
meta-xilinx-standalone/recipes-bsp/embeddedsw/fsbl-firmware_2024.2+git-generic.inc
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,10 +1,3 @@ | ||
SKIP_MSG = "" | ||
SKIP_MSG:zynq = "Generic support for zynq is not available" | ||
SKIP_RECIPE[fsbl-firmware] = "${SKIP_MSG}" | ||
|
||
FILESPATH .= ":${FILE_DIRNAME}/embeddedsw/${PV}:${FILE_DIRNAME}/embeddedsw" | ||
|
||
SRC_URI += " \ | ||
file://makefile-skip-copy_bsp.sh.patch \ | ||
file://fsbl-fixups.patch \ | ||
" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Oops, something went wrong.