forked from codescoop/Play-with-Data-Structures
-
Notifications
You must be signed in to change notification settings - Fork 0
/
08_pattern _inverted_HourGlass.cpp
79 lines (68 loc) · 1.89 KB
/
08_pattern _inverted_HourGlass.cpp
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
/*
Pattern Inverted HourGlass
Take N as input. For a value of N=5, we wish to draw the following pattern :
5 5
5 4 4 5
5 4 3 3 4 5
5 4 3 2 2 3 4 5
5 4 3 2 1 1 2 3 4 5
5 4 3 2 1 0 1 2 3 4 5
5 4 3 2 1 1 2 3 4 5
5 4 3 2 2 3 4 5
5 4 3 3 4 5
5 4 4 5
5 5
Input Format: Take N as input.
Output Format: Pattern should be printed with a space between every two values.
Sample Input: 5
Sample Output: 5 5
5 4 4 5
5 4 3 3 4 5
5 4 3 2 2 3 4 5
5 4 3 2 1 1 2 3 4 5
5 4 3 2 1 0 1 2 3 4 5
5 4 3 2 1 1 2 3 4 5
5 4 3 2 2 3 4 5
5 4 3 3 4 5
5 4 4 5
5 5
*/
#include<iostream>
using namespace std;
int main() {
int total_rows;
cin >> total_rows;
int nop = 1;
int nos = (total_rows*2)-1;
for(int row=1; row<=(total_rows*2)+1; row++){
int val = total_rows;
// for pattern
for(int cop=1; cop<=nop; cop++){
cout << val <<" ";
val--;
}
// for space
for(int cos=1; cos<=nos; cos++){
cout << " ";
}
// for pattern
for(int cop=1; cop<=nop; cop++){
if(nop == total_rows+1 && cop == 1){
cop++;
val++;
}
val++;
cout << val << " ";
}
// for next iteration
if(row < total_rows+1){
nop++;
nos = nos-2;
}else{
nop--;
nos = nos+2;
}
cout << endl;
}
return 0;
}